Brother HL-2030 unter Linux

Nunja, oben genannten Drucker habe ich nun und bin damit auch voll zufrieden.
Halt ein kleiner Laserdrucker der mal ebend dei 200-Seiten-Skripte einiger Dozenten kostengünstig auf Papier bannen kann.

Da ich letztens mein Linuxsystem zerlegt habe (wohl gemerkt nach nun ~3 Jahren das erste Mal) musste selbiger neu installiert werden.

Es gibt auch schöne Treiber von Brother (was die Trennung in LPR und Cups-Treiber soll weiß ich nicht, aber es funzt und GPL isses auch nocht):
http://solutions.brother.com/linux/sol/printer/linux/cups_drivers.html
http://solutions.brother.com/linux/sol/printer/linux/lpr_drivers.html

Die Installation ist denkbar einfach wenn man weiß wie:

Zuerst das LPR und Cups-Paket runterladen und dann gehts los:
(Dies gilt für ein Debiansystem mit Cups)

  1. apt-get install lpr
  2. dpkg -i --force-all brhl2030lpr_1.1.2-3_i386.deb
  3. dpkg -i --force-all cupswrapperhl2030_1.0.0-1_i386.deb
  4. apt-get remove lpr

Ja lpr muss installiert sein auch wenn Cups zum Drucken genutzt wird!

Ein letzter Fallstrick ist in den neueren Cups-Versionen enthalten.
/dev/usb/lp0 ist nicht mehr gültig (Probleme mit hotplug etc). Es muss ein Gerät angegeben werden welches genau dem Brother zugeordnet werden kann.
Dies geht am einfachsten über die Druckerverwaltung, hier am Beispiel von KDE:
KControlCenter starten > Angeschlossene Geräte > Drucker > HL2030 makieren > Eigenschaften > Schnitstelle > Ändern > Lokaler Drucker
Dann soltle schon ein passendes Gerät vorgeschlagen werden, bei mir war es
usb://Brother/HL-2030%20series
Ein letzter Klick auf Abschließen und das war’s.

Eigentlich ganz einfach nur mit den üblichen Fallstricken die man bei Debian gerne einbaut *gg*

11 Antworten auf „Brother HL-2030 unter Linux“

  1. Ich habe hier auch einen Brother HL-2030 an einem Debian 3.1 Server unter Cups. Als Druckertreiber taucht in der Standard-Installation nur der hl-1250 bzw. der 2060 auf.

    Die Pakete von Brother (in den aktuellen Versionen) hab ich wie oben installiert, dennoch taucht der Drucker in der Liste der CUPS Drucker (unter „Brother“ nicht auf).

    Irgendeine Idee?

    Gruß,

    Christoph

  2. Hallo Christoph,

    du kannst einfach den 2060-Treiber nehmen. Der funktioniert bei mir ohne Probleme.

    Wie oben beschrieben sollte bei der Treiberinstallation eigentlich ein Drucker automatisch angelegt werden. Wie man ihn manuell mit den richtigen Treibern anlegt weiß ich auch nicht.
    Funktioniert ja mit dem 2060 😉

  3. Hallo,

    Mein Drucker hat bisher immer funktioniert, doch dann ging nichts mehr zu drucken,
    Ohne Vorwarnung.
    Unter Windows hab ichs probiert, geht.
    Habe jetzt nochmal alles neu installiert, aber trotzdem, kein muks.
    Hab auch schon den USB-Port gewechselt. Ich weiß nicht mehr weiter 🙁
    Danke für eure Hilfe.

    MFG, Alexander

  4. So ist die Fehlerdiagnose immer rel. schwer.

    Am besten ist es wohl, wenn du das Loglevel auf INFO oder so hochsetzt.
    Alternativ einfach mal die HL2060-Treiber aus dem Gimpprinting-Paket probieren. Die funktionieren hier ohne Probleme

  5. Ja, danke schonmal für die Antwort.
    Also, ich habe zzt. den 2060-Treiber installiert.
    Folgender Fehler steht im Log:
    E [19/Feb/2007:20:06:49 +0100] PID 5864 (/usr/lib/cups/cgi-bin/printers.cgi) crashed on signal 9!

    weiß nicht, ob jemand was damit anfangen kann ^^ ich jedanfalls ohne weiteres nicht
    Danke

  6. Halt, moment ^^
    der log hat unten die neusten Einträge xD

    D [12/Jun/2007:19:52:04 +0200] cupsdReadClient: 123 GET /images/esp-logo.gif HTTP/1.1
    D [12/Jun/2007:19:52:04 +0200] cupsdReadClient: 123 Browser asked for language „de-DE.utf8″…
    D [12/Jun/2007:19:52:04 +0200] cupsdAuthorize: No authentication data provided.
    D [12/Jun/2007:19:52:04 +0200] cupsdSendError: 123 code=304 (Not Modified)
    D [12/Jun/2007:19:52:07 +0200] cupsdReadClient: 7 GET /admin/log/error_log HTTP/1.1
    D [12/Jun/2007:19:52:07 +0200] cupsdReadClient: 7 Browser asked for language „de-DE.utf8″…
    D [12/Jun/2007:19:52:07 +0200] cupsdAuthorize: No authentication data provided.

    das sind so die letzten Zeilen.
    immer das gleiche

  7. tach

    ich klinke mich mal hier mit ein. Benutze zwar Ubuntu dürfte aber das selbe problem sein.Mein Hl 2030 ist jetzt über ein Jahr Problem los gelaufen und heute stell ich fest das der cupsys server aufeinmal weg ist und ich garnichtsdrucken konnte
    den hab ich dann wieder installiert drucker wieder eingerichtet
    dan lies sich die qualität und die Einstellungen papierformat…. nicht verändern
    nun kann ich zwar wieder unter Openoffice und Firefox drucken
    aber pdfs so wie Bilder nicht
    immer wen man es braucht
    vielleicht findet ihr ja ne lösung
    gruß pascal

  8. Also ich empfehle nochmal ausdrücklich, sofern die Orginaltreiber nicht funktionieren einfach die HL-2060-Treiber zu nehmen.
    Die sind bei Cups/Foomagic automatisch für alle Plattformen (anscheind) vorhanden.
    Einfach diesen Treiber wählen und gut ist.
    Nutze ich nun seit über einem Jahr mit x86 und x64 ohne Probleme.

    Viele Grüße

Schreibe einen Kommentar