Java-Version mittels ANT-Task überprüfen

Hin und wieder muss man die Java-Version dann doch überprüfen, wenn man mittels ANT Buildscript eine Javaapplikation bauen will.

Blöderweise landet man bei entsprechenden Google-Suchen immer nur auf einem Beispiel (oft kopiert auf diversen Seiten wie jguru.org etc. – Nein ich werde die Beispiele hier nicht verlinken)

Die Beispiel sind ganz toll, aber furchtbar unübersichtlich. Und da ANT 1.7 nun doch schon ein Weilchen draußen ist, kann man seine Featuers auch nutzen:

	
	

Entgegen des alten Vorgehens wird eine Property gesetzt, wenn nicht mindestens Java 1.6 zur Verfügung steht.
Da wir nicht wissen, wie Sun seine nächsten Javas nennen wird mache ich es so umgedreht.

Nutzen kann man den Schnipsel dann so (Ja das ist inspiriert von den alten Beipsielen):

	
	
		
	


	


	

Schreibe einen Kommentar