Admin-SSL mit WP 3.1 überflüssig

Mit dem Update auf WordPress 3.1 gab es zum 1. Mal über das (äußert praktische) automatische Update ein Problem:

  1. Fatal error: Cannot redeclare user_can() (previously declared in /home/flexiscr/public_html/wp-includes/capabilities.php:1099) in /home/flexiscr/public_html/wp-content/plugins/admin-ssl-secure-admin/admin-ssl.php on line 113

Wie man sieht, bin ich nicht alleine: WP Forum

Das o.g. Problem wird durch ein „uraltes“ Plugin ausgelöst: admin-ssl-secure-admin

Wie man nun feststellt, ist oben genanntes Plugin seit Jahren (seit WP 2.6^^) gar nicht mehr nötig: Geschwind die wp-config.php angepasst und fertig. Details findet man hier: http://codex.wordpress.org/Administration_Over_SSL.

Sehrsehr hübsch 🙂

Und für alle, bei denen das Kind schon in den Brunnen gefallen ist (und die Seite nicht mehr erreichbar ist):
Einfach per FTP/SSH das Plugin-Folder von admin-ssl-secure-admin löschen. Danach über die Plugin-Verwaltungsseite das Plugin endgültig löschen.

Schreibe einen Kommentar